L'actualité ...

CMS Made Simple™ 2.0

07/09/2015

Une nouvelle version 2.0 est sortie avec de nombreuses modifications

Pour information  le forum


La configuration minimale requise est la version PHP 5.4.11, recommandé 5.5.2 ou 5.6.X
la page téléchargement sur cmsmadesimple.org

Assistant Installation/Mise à jour CMSms V2


Le téléchargement est possible suivant 2 possibilités :
A- Nouveau système d'installation/mise à jour en un seul fichier PHAR (Recommandé)
(comprend l'installateur et tous les fichiers de CMSms). cmsms-2.0-install.zip
1 - Décompacter le fichier cmsms-2.0-install.zip
2 - Cela va créer un fichier cmsms-2.0-install.php
Lisez attentivement le fichier README-FR-PHAR.TXT
3 - A l'aide de votre navigateur, accédez fichier cmsms-2.0-install.php

B- Variante pour les serveurs incompatibles avec le PHAR (si le PHAR ne fonctionne pas)
Jeu de fichiers cmsms-2.0-install.expanded.zip
1 - Utiliser le gestionnaire de fichiers de votre Hébergeur créer un nouveau sous-dossier, dans le dossier /cms dans lequel vous souhaitez installer CMSMS. exemple vous pouvez nommer ce dossier cmsms_install
Par exemple : /public_html/cms/cmsms_install
- CMSMS sera installé dans /cms
- les fichiers de l’installateur seront dans cmsms_install
2 - Uploadez le fichier cmsms-2.0-install.expanded.zip dans ce sous-dossier.
3 - Extraire les fichiers de l'archive zip dans ce sous-dossier.
Cela va créer de nombreux fichiers et dossiers. Donc faites attention que vous extrayez les fichiers dans le dossier approprié.
4 -  A l'aide de votre navigateur, accédez au dossier créé à l'étape 1.
Par exemple: http://www.monsitewebe/cms/cmsms_install

ATTENTION mise à jour depuis 1.12 uniquement wink
Avant la mise à jour assurez-vous de :
Il est fortement conseiller de faire un test en local.
A : Vérifier que tous vos modules sont compatible avec CMSMS 2.0 avant d'effectuer cette mise à niveau,
B : Assurez-vous que vous avez mis à jour tous les modules à leur dernière version disponible, cela devrait vous assurer que vos modules sont compatibles avec CMSMS 2.0,
C : Assurez-vous que vous avez une sauvegarde vérifiée de tous vos fichiers et de la base de données avant la mise à jour pour restaurer en cas d'erreur,
D : Lire en détail les annonces, notes de mise à jour et la documentation (inclus le fichier README.txt de l'installateur) avant de procéder à cette mise à jour.
- Si vous utilisez TinyMCE ce module est incompatible avec cette version 2.0, il
faut donc installer et utiliser MicroTiny obligatoirement.

Version Australia
- PHP minimum =>5.4.11 recommandé =>5.5.5 ou plus
- Ajout du module Recherche dans Administration : AdminSearch V 1.0
- Ajout du module DesignManager (Gabarits+menu+gestion styles) V 1.0
- Ajout du module Navigator (Navigation) V 1.0
- Ajout du module CMSContentManager : gestions des contenus V 1.0
- CmsMailer devient obsolète, reste la classe phpmailer passe dans le dossier /lib
- Refonte de ModuleManager
- La configuration mail se fait dans le menu Paramètres globaux
Changement des balises : Search remplace search, News remplace news, Navigator remplace menu
- CMSPrinting V 1.5 NOTA le module est supprimé
- News V 2.50 + Search V 1.50 + CMSMailer V 5.2.4 +FileManager + ImageEditor + MenuManager V 1.50 + ModuleManager V 2.0
+ MicroTiny V 2 avec tinymce 4.1.10 avec plugins
- Nettoyage du code, refonte de l'installation + Création table locks
- Mise à jour de Smarty V 3.1.27 (12/07/2015) -> retour à 3.1.16
- Suppression des fichiers et en particuliers du fichier fileloc.php et de différents plugins
- Modification des fichiers de langues dans /admin/lang/
- Suppression du thème administration NCleanGrey - Interface Admin en HTML5
- Modifications de timezone
- Mise à jour de jquery 1.11.1 et jquery-ui 1.10.4
- Révision installateur et mise à jour
- Modification du thème Simplex design
- Ajout balise share_data (31/05/2015)
- Modification de la balise page_attr (03/06/2015)
- ATTENTION Lire les fichiers texte de l'installateur



Page précédente : DraftSight Debian 8